oTree Forum >

Unavailable to the data export

#1 by Josie

I waited for a long time and got nothing. I'm not sure whether the data is too large to download.
I have upgraded the Postgres plan and the Dyno size, but nothing changed.
Is there any other way to download the data?

#2 by Chris_oTree

Can you add chris@otree.org as a collaborator on the Heroku app? I can take a look.

#3 by Josie

Hello Chris,
I have added you as a collaborator. Thanks.

#4 by Chris_oTree

For now I recommend restarting the dynos and then download the per-app data exports. It looks like there is a very large amount of data in the DB, so the combined export may be too big.

#5 by Josie

Ok! I'll download the per-app data. Thank you!

#6 by ccrabbe

Hi Chris_oTree -

On this topic - when there is an Exception in custom_export, this is the same behavior that happens.  The "working" spinner just spins forever, despite execution having halted.  It can be hard to tell whether it's a correctly functioning export taking a long time or whether there's an error happened.

Is it possible or convenient to catch an exception in custom_export and display an error icon or small error message on the data export page instead of having that spinner keep spinning?  That would solve this confusion on whether it's just taking a long time or something bad has happened.


#7 by Chris_oTree

Hi Chris, that's a good idea, I've just implemented this and published the update. Thanks for suggesting!

#8 by gonarr

Hi Chris,

I am having the same issue with the data being too large to download even in per-app (I only have one app). Any suggestions? thanks.

#9 by gonarr

Hi Chris,

I want to follow up on this since I am having the same error when trying to export data. I have tried restarting the dynos and then download the per-app data exports. The per-data exports fine but the custom_export doesn't, which makes the data useless. The session-wide export is the one I normally use, but the app crashes giving this error in Heroku logs:
2023-04-10T15:51:25.195584+00:00 heroku[router]: at=error code=H12 desc="Request timeout" method=GET path="/ExportSessionWide/vazmq6kw?token=2e1af5e2&excel=1" host=ab2022inference.herokuapp.com request_id=c4108bd0-62d1-4c19-b0b1-dd48757a0a43 fwd="" dyno=web.6 connect=0ms service=30001ms status=503 bytes=0 protocol=https

Is there any other way to download the data? Thank you.

#10 by gonarr

I'm getting this same error. Please help?

Write a reply

Set forum username