oTree Forum >

Getting Stuck on creating_session in heroku

#1 by woodsd42 ,

Hi,

I have a strange issue that has been going on for quite some time now.  The problem persists over different browsers and internet connections.  My colleague codes up something in otree, pushes it to heroku, and everything works fine for him.  However, when I go to use the herokuapp, I cannot get past creating_session - it always gets stuck and the session never begins.  My colleague is able to do this just fine - and I can test out the experiment after he creates the session and emails me the links. This has been a sufficient workaround, however, now I am going to be conducting lab experiments using this software, and this will be prohibitively inconvenient.

Any idea what could be going on here?  I'm happy to give more information, I'm just not sure what will be useful, because this has completely stumped me.

Best Regards,
Daniel Woods

#2 by Chris_oTree ,

Hi, can you provide me with a link to the server? chris@otree.org

#3 by Chris_oTree ,

(even better, add chris@otree.org as a collaborator on the heroku app)

#4 by woodsd42 , (edited )

Ok, I think you've been added as a collaborator just now.

#5 by Chris_oTree ,

I tried it on Chrome and Firefox but it works fine for me also. Tried both with demo mode and through the "Sessions" page, with a couple session configs.

#6 by Chris_oTree ,

Maybe try from a different computer or internet connection and let us know if it persists.

#7 by woodsd42 ,

Hi, sorry for the delay - it works fine on other connections so I have isolated the problem to the university's network.  I have the IT department checking whether it is some firewall issue or similar.  I hadn't tried it on another computer recently, because we have been using the workaround for a while now, so we didn't recognize when whatever the original issue was became resolved.

Write a reply

Set forum username