oTree Forum >

Could not get the build result

#1 by qzyyb123

Hi everyone,

I've encountered a problem when uploading my otree.zip file. It works fine when I run my sessions yesterday.

While I checked my Heroku, it seems fine.

Any suggestion is greatly appreciated!

#2 by Chris_oTree ,

Can you show a screenshot of your 'configure' tab in oTree Hub? Any errors or warnings there?

#3 by qzyyb123

Hi Chris,

Thanks for your quick response. Please see attached for the screenshot.

#4 by qzyyb123

Hi Chris,

It seems fixed automatically now. The time built up is 22 minutes ago which is much longer than expected. Still not sure what is wrong before.

#5 by qzyyb123

Hi Chris,

The problem seems to happen again when I reupload the zip file. Only when I refresh my page does it say the build result is successful. Is there anyway to fix it?

#6 by gonarr

I am having the exact same problem, only it never builds successfully for me. Any solutions? Many thanks!

#7 by Chris_oTree ,

Can you show a screenshot of your browser's JavaScript console after you upload a file and have waited for a bit? (right-click and go to developer tools)

#8 by gonarr

I have attached the screenshot. 
Importantly: the app seems to work fine when I go to the link! I hadn't tried this before since I always get the "Could not get the build result." red alert, but I tried it now and the app seems to work perfectly fine...

#9 by Chris_oTree ,

I looked in the logs and Heroku is not sending the requested notifications about the build status back to oTree Hub. I don't know why. Their status page says it's working fine but I'm not sure.

#10 by Chris_oTree ,

Yep, now Heroku reports that there is a problem with webhook notifications: https://status.heroku.com/incidents/2476

#11 by qzyyb123

Thank you, Chris!

Write a reply

Set forum username