oTree Forum >

Dyno scaling error when deploying project via Heroku

#1 by lea_s2

Hi all, 

I am currently working on deploying a project via Heroku, but whenever I try to upload my project via the tab in the oTree Hub, I get the following error message: 

-----> Launching...
!     Subscribe to Eco to scale your dynos. Learn more at https://blog.heroku.com/new-low-cost-plans
!     Push failed

I’ve tried to subscribe to scale my dynos in Heroku, but this requires there already being a Procfile in my Heroku project, which (from what I understand) typically won’t be the case until I have uploaded the project. I have tried uploading just the needed Procfile by connecting to Heroku via Github, but this has not worked either. 

Does anyone know how to scale up the dynos in Heroku to avoid the above error, or an easy way to add the Procfile without uploading the entire project via oTree Hub? 

Thanks in advance!

#2 by Chris_oTree

You should be able to subscribe to Eco dynos before deploying, since it's something you do globally: https://dashboard.heroku.com/account/billing

#3 by lea_s2

This link worked, thank you!

#4 by Chris_oTree

Great. I have added a note about this to the deploy tab.

Write a reply

Set forum username