oTree Forum >

Error when trying to publish to mturk

#1 by Elias (edited )

Hello everyone,
I get the following error when I am trying to submit to Mturk (sandbox or not) from otree:

ValueError: Invalid header value b'AWS4-HMAC-SHA256 Credential=MY_AWS_KEY\n/20221229/us-east-1/mturk-requester/aws4_request, SignedHeaders=content-type;host;x-amz-date;x-amz-target, Signature=my_signature'

I have obfuscated the real keys, but I have checked they are the ones I get in AWS.
Any help would really be appreciated.
Elias

#2 by Elias_2 ,

Hello everyone,

I have generated new AWS access keys for and I still get the following error when trying to publish to the Sandbox. I have not tried a real experiment.

 MTurkError({'__type': 'RequestError', 'Message': 'This user is not authorized to perform the requested operation. (1674227153344 s)', 'TurkErrorCode': 'AWS.MechanicalTurk.PermissionDenied'}) 
 
I have given the access policy AmazonMechanicalTurkFullAccess to the user corresponding to the keys above. Is it the wrong one?
Many thanks!
Elias

P.S.: I am the same me who posted before, but changed institution and changed email.

Write a reply

Set forum username