oTree Forum >

Deleting database

#1 by Anwesha

Hi everyone,

Hope you are well. I was trying to test my codes and then I recived this error message: oTree has been updated. Please delete your database (db.sqlite3). Could you kindly guide me on how I can delete this database? I tried doing it manually, but was unable to figure it out.

#2 by Fanist

I think deleting the file manually works well for me. What is the difficulty here?

#3 by Fanist

Another way can be insert the command into the terminal:
otree resetdb

and input "y" to delete the database.

#4 by Anwesha

Hi @Fanist,

Apologies for the delayed response. I tried this method but it still doesn't solve the problem. Since I am new to programming, I am not sure how to manually delete it.

#5 by Anwesha (edited )

Hi @Fanist,

Apologies for the second response. I have figured it out. Looks like one of my co-authors created the database while experimenting with the codes. Now I can manually delete it after asking him. Thank you so much.

Write a reply

Set forum username