oTree Forum >

otree 3 devserver error: ValueError: No route found for path 'session_monitor/

#1 by Scott

I have several otree 3 apps that are still active and being maintained and developed. When I run them from the command line I get the following error. I have tried from PowerShell, WSL with Ubuntu 20 and 22, using venv's with python 3.7 and 3.8 and otree 3.3, but I always get the same error. Any ideas?

Error in ASGI Framework
Traceback (most recent call last):
  File "d:\venv\wotree3p7\lib\site-packages\hypercorn_otree\asyncio\spawn_app.py", line 14, in _handle
    await invoke_asgi(app, scope, receive, send)
  File "d:\venv\wotree3p7\lib\site-packages\hypercorn_otree\utils.py", line 198, in invoke_asgi
    asgi_instance = app(scope)
  File "d:\venv\wotree3p7\lib\site-packages\channels\routing.py", line 54, in __call__
    return self.application_mapping[scope["type"]](scope)
  File "d:\venv\wotree3p7\lib\site-packages\channels\sessions.py", line 47, in __call__
    return self.inner(dict(scope, cookies=cookies))
  File "d:\venv\wotree3p7\lib\site-packages\channels\sessions.py", line 145, in __call__
    return SessionMiddlewareInstance(scope, self)
  File "d:\venv\wotree3p7\lib\site-packages\channels\sessions.py", line 169, in __init__
    self.inner = self.middleware.inner(self.scope)
  File "d:\venv\wotree3p7\lib\site-packages\channels\middleware.py", line 31, in __call__
    inner_instance = self.inner(scope)
  File "d:\venv\wotree3p7\lib\site-packages\channels\routing.py", line 150, in __call__
    raise ValueError("No route found for path %r." % path)
ValueError: No route found for path 'session_monitor/9wqck4kc'.


Write a reply

Set forum username