oTree Forum >

Otree not running on mac terminal -

#1 by tedd

Hi Chris,

I am trying to run otree using the code 'otree zipserver' but I keep getting error messages. I tried both uninstall and re-installing python and otree. Please see the screenshot for error messages.

I would appreciate your help - Thanks.

#2 by Chris_oTree

See the last line. A LongStringField cannot have choices, so you should change it to a StringField.

#3 by tedd

OK, Thanks. What I am confused is, this otree.zip file worked well when I was running it a couple of years ago. Is there a way to work through it without changing any settings?

#4 by tedd

I am asking because it is not only that one in LongStringField but there are multiple of them. Also, I am not trying to run it to have another experiment, but trying to take screenshots, so I don't care about the stability by keeping them as LongStringField. 

As I am using oTreeStudio, it will take a while to change all. 


#5 by Tedquestion (edited )

FYI, the above screenshot is when I purposefully tried using a prior version of Python because the newest version of 3.11 did not seem to work. I just reset it back to the most recent version of Python and oTree. Could you please take a look at this screenshot and see what the issue is? I don't think the LongSTringField is an issue now.


Write a reply

Set forum username